Configuration Réseau & Wi-Fi pour le VoCore

Quand on déballe le VoCore et qu’on l’alimente, on obtient un nouveau réseau Wi-Fi avec le SSID Vocore_xxx qui sert des IP dans le réseau 192.168.61.0. Le routeur lui-même a l’adresse 192.168.61.1. C’est bien.

Mais moi, je veux (et j’exige) qu’il se connecte à mon Wi-Fi local et qu’il demande une IP à ma box. Il a fallut batailler un peu pour obtenir une configuration stable, mais voici les fichiers de référence pour cette configuration.

root@OpenWrt:~# cat /etc/config/network

# L'adresse de loopback
config interface 'loopback'
 option ifname 'lo'
 option proto 'static'
 option ipaddr '127.0.0.1'
 option netmask '255.0.0.0'

config globals 'globals'
 option ula_prefix 'fdef:739b:c053::/48'

# Le réseau installé par défaut pour le routeur
config interface 'lan'
 option ifname 'eth0.1'
 option force_link '1'
 option macaddr 'b8:d8:12:66:0a:cc'
 option type 'bridge'
 option proto 'static'
 option ipaddr '192.168.61.1'
 option netmask '255.255.255.0'

config switch
 option name 'switch0'
 option reset '1'
 option enable_vlan '1'

config switch_vlan
 option device 'switch0'
 option vlan '1'
 option ports '0 4 6t'

# Le client DHCP activé pour le réseau Wi-Fi local
config interface 'wwan'
 option proto 'dhcp'

root@OpenWrt:~# cat /etc/config/wireless

# La config Wi-Fi par défaut mais avec écoute sur canal 6 (ma box)
config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path '10180000.wmac'
        option htmode 'HT20'
        option channel '6'
        option txpower '20'
        option country 'FR'

# La config Wi-Fi par défaut, juste désactivée
config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'VoCore_660ACC'
        option encryption 'none'
        option disabled '1'

# La config Wi-Fi de ma Box
config wifi-iface
        option network 'wwan'
        option ssid 'XXXXXXXXX'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'sta'
        option bssid 'XX:XX:XX:XX:XX:XX'
        option key 'XXXXXXXXXXXXXX'

root@OpenWrt:~#

Et ça, ça marche !

Bon, je n’ai pas testé le port Ethernet pour savoir comment il se comporte, mais ce n’est pas mon besoin en même temps.

boot2docker

Pour jouer un peu et découvrir Docker, j’avais besoin d’installer certains outils. Voici quelques unes de mes errances en espérant que cela pourra vous éviter quelques pièges.

Note : je sais bien qu’il y a un installateur pour Docker sur Windows, mais… ça ne fonctionne qu’en Windows 64bits et que ce n’est pas le cas pour ma machine pro.

Continuer la lecture de « boot2docker »

Un club électronique dans l’Essonne ?

Ça fait plusieurs fois que lors de rencontres libres et/ou cartographiques mes interlocuteurs déplorent le manque de club d’électronique.
Je me suis donc lancé dans la constitution d’un groupe.
Le principal objectif étant de trouver un local pour se rencontrer IRL. Si vous avez de idées, la connaissance d’une association qui pourrait héberger ce groupe, je suis intéressé.

Luciole numérique

L’idée

Projet de luciole basé sur plusieurs projets dont une démo de @asthrolab rencontré à l’OpenBidouilleCamp de Montreuil (déc. 2013).

luciole NE555© 2013 par Asthrolab

Après recherche, c’est un classique de l’électronique personnelle dont on retrouve des références de par le monde, comme chez David DARTS (aussi à l’origine du concept de la PirateBox) et la LEDfirefly.

Continuer la lecture de « Luciole numérique »

Rediriger un socket vers le port série

Toujours plus loin dans le MR-3020 et l’Arduino Nano connecté dessus !

Aujourd’hui j’ai pu mettre en œuvre mon afficheur à matrices de leds et le rendre accessible depuis mon réseau local. Je vous laisse regardé l’article précédent qui indiquait la prise en charge de l’Arduino Nano via sa connexion USB sur le MR-3020.

Continuer la lecture de « Rediriger un socket vers le port série »

MR-3020 & convertisseur USB-Serial FTDI

20130810_000642Une bidouille sur Arduino Nano , mais comment la faire communiquer ?

Mieux qu’un shield Ethernet, un routeur Linux OpenWrt MR-3020 !

On branche l’Arduino via un hub usb (c’est expliqué ici pourquoi) sur le port USB du MR-3020.

Continuer la lecture de « MR-3020 & convertisseur USB-Serial FTDI »

MR-3020 et clé USB Audio

 

20130802_002523

Après toute l’énergie que j’ai mise pour faire fonctionner MPD sur le Raspberry PI, je tombe sur un article de Dangerous Prototypes qui décrit comment mettre une clé usb audio sur ce petit routeur. Mon sang ne fait qu’un tour : je dois au moins relever ce défit ! Et voilà la résultat ci-dessous.

Continuer la lecture de « MR-3020 et clé USB Audio »

Un référentiel géographique

Le point de départ de cette étude est une question de principe que l’on m’a posée récemment :

«

— Comment synchroniser un référentiel géographique propriétaire avec OpenStreetMap ?
Et la réponse qui vient automatiquement :
— Impossible ! On ne peut pas synchroniser plusieurs référentiels !

»

La réponse est un peu courte et assez décevante alors creusons un peu le sujet.

Continuer la lecture de « Un référentiel géographique »

Des matrices de LEDs

Dans le cadre d’un prototypage, j’ai participé à une collecte de fond pour réaliser une carte intégrant :

  • une matrice de led 8×8, et
  • un driver Maxim 7219 contrôlable par bus i2c.

le tout, chaînable à volonté (ou presque, à la limite de courant près). Vous pouvez retrouver le produit ici : LED Matrix Link.

Le seuil de déclenchement du projet a été atteint et je devrais recevoir mes composants d’ici 1 mois.

Ajoutons-y un Arduino Nano avec sa connexion USB et hop ! voici un afficheur commandable par PC… pour afficher ses tweets au fil de l’eau par exemple.